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When creating complex artwork, you will want to keep track of all of your objects. As you work, small items 
can get hidden under larger items, and it may become difficult to select certain items. Layers provide an easy 
way to manage your artwork. Think of layers as transparent planes on which your artwork exists. The planes 
are represented by folders in the Layers palette. If you reshuffle the folders, you change the stacking order of 
the items in your artwork.

The Layers Palette
The structure of layers in your document is displayed in the Layers palette and can be as simple or complex 
as you want it to be. You use the Layers palette to name, list, organize, and edit the objects in a document. 
By default, every new document contains one layer, and each object you create is listed under that layer. 
However, you can create new layers and move items between layers at any time. You can also use the Layers 
palette to select, hide, lock, and change the appearance attributes of artwork. You can even exchange layers 
with Photoshop. To display the Layers palette, choose Window > Layers (See Figure 1).

By default, Illustrator assigns a unique color to each layer in the Layers palette. The color displays in the 
layer’s selection column when one or more objects within the layer are selected. In addition, the same color 
displays in the document window in the bounding box, path, anchor points, and center point of the selected 
object to quickly locate an object’s corresponding layer in the Layers palette.

When an item in the Layers palette contains other items, a triangle appears to the left of the item’s name. 
Click the triangle to expand or collapse the list of contents. If no triangle appears, the item contains no addi-
tional items.

1.) Using Layers

Figure 1 – The Layers Palette
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Layers Palette Functions

A: Visibility controls whether items are visible or hidden. The eye icon indicates that the item is visible; a 
blank space indicates that the item is hidden.
H: Edit Column (Lock/Unlock) controls whether items are locked or unlocked. The lock icon indicates that 
the item is locked and cannot be edited; a blank space indicates that the item is unlocked and can be edited.
E: Target – a double ring indicates that the item is targeted and you can apply effects and edit attributes in 
the Appearance palette. A single ring icon indicates that the item is not targeted.
D: Selection –A selection color box indicates that the item or an item within the layer or group is selected in 
the document.

Display Options
You can modify how layers, groups, and objects are displayed in the Layers palette.
•	 From the Layers palette menu choose Palette Options to open the Layers Palette Options dialog box (See 

Figure 2).
•	 Select Show Layers Only to hide paths, groups, and collective elements in the Layers palette.
•	 For Row Size, select an option to specify the height of rows. (To specify a custom size, enter a value 

between 12 and 100.)
•	 For Thumbnails, select a combination of layers, groups, and objects for which to display thumbnail 

previews.

Creating Layers
•	 In the Layers palette, click on the layer above which (or in which) you want to add the new layer.
•	 To add a new layer above the selected layer, click the Create New Layer button at the bottom of the Lay-

ers palette.
•	 To create a new sublayer inside the selected layer, click the Create New Sublayer button in the Layers 

palette.
•	 To set options as you create a new layer, choose New Layer or New Sublayer from the Layers palette 

menu.

Figure 2 – Layer Palette Display Options dialog box
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Layer Options
To set the options for any existing item in the Layers palette, double-click the item name or click the item 
name and choose Options For… from the Layers palette menu.

Name specifies the name of the item as it appears in the Layers palette.
Color (Layers only) specifies the layer’s color setting.
Template (Layers only) makes the layer a template layer.
Lock prevents changes to the item.
Show displays all artwork contained in the layer on the Artboard.
Print (Layers only) makes the artwork contained in the layer printable.
Preview (Layers only) displays the artwork contained in the layer in color instead of as outlines.
Dim Images (Layers only) reduces the intensity of linked images and bitmap images contained in the layer 
to the specified percentage.

Moving Objects
You can move objects between layers or to a different position within the same layer.

To move an object in the Layers palette:
•	 Locate the object in the Layers palette.
•	 Drag the object to the desired location. Watch for the black indicator lines that indicate where the object 

will be placed when you release the mouse button.
---------- or ----------
Drag the selected-art indicator located at the right of the layer in the Layers palette to the layer you want. 
(Object must be selected first.)

Tip:You can move objects or layers into a new layer by selecting them and choosing Collect In New 
Layerfrom the Layers palette

Viewing Outlines
You can use the Layers palette to display some items as outlines and other items as they will appear in the 
final artwork. You also can dim linked images and bitmap objects to make it easier to edit artwork on top of 
the image. This is especially useful when tracing a bitmap image.

•	 To view all artwork in a layer as outlines, Ctrl‑click the eye icon for that layer in the Layers palette. 
Ctrl‑click again to return to previewing the artwork in color. The eye icon has a hollow center when 
Outline view is enabled and a filled center when Preview view is enabled.

•	 To view all unselected items in the Layers palette as outlines, Alt+Ctrl‑click the eye icon for the select-
ed item or select Outline Others from the Layers palette menu.

•	 You can return all items in the Layers palette to Preview mode by choosing Preview All Layers from the 
Layers palette menu.

Figure 3 – Layer Palette Options
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Stacking Order

How objects are stacked determines how they display when they overlap. The stacking order of objects cor-
responds to the hierarchy of items in the Layers palette. Objects higher in the stacking order (towards the top 
of the Layers palette) will appear on top of or in front of objects that are lower in the stacking order (towards 
the bottom of the Layers palette). There are two main methods of changing the stacking order (also called 
the painting order):

•	 Drag them in the Layers palette.
•	 Use the Object > Arrange commands.

Changing the Stacking Order Using the Layers Palette

•	 Drag the item and release the mouse button when black insertion marks appear in the desired position. 
Black insertion marks appear either between two other items in the palette or on the left and right edges 
of a layer or group. Items that are released over a layer or group are moved above all other objects in that 
layer or group.

•	 Drag the item’s selection color box to a different item’s selection color box and release the mouse but-
ton. If the item’s selection color box is dragged to an object, the item is moved above the object; if it’s 
dragged to a layer or group, the item is moved above all other objects in that layer or group.

•	 To reverse the order of items in the Layers palette, Ctrl-click the items whose order you want to reverse 
and select Reverse Order from the Layers palette menu. The items must be at the same level in the layer 
hierarchy. For example, you can select two top-level layers, but you cannot select two paths that are in 
different layers.
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Photographs are typically saved as bitmap images, also known as raster images. Raster images use a grid 
of small squares known as pixels to represent the image. Each pixel is assigned a specific location and color 
value. When working with bitmap images, you edit pixels rather than objects or shapes as you do with Illus-
trator’s vector art. Unlike vector art, bitmap images are resolution-dependent—that is, they contain a fixed 
number of pixels. As a result, they can lose detail and appear jagged if they are scaled on-screen or resized.

You can combine vector graphics and bitmap images to create bitmap effects in your artwork using filters, 
effects, and graphic styles. However, remember that how your artwork looks in Illustrator isn’t always how 
it will look in its final medium. A few things that may influence the quality of your final artwork include:

•	 Transparency – When your artwork contains transparency, Illustrator performs a process called flatten-
ing before printing or exporting. In most cases, the default flattening process produces excellent results. 
However, artwork containing complex, overlapping areas with require high-resolution output should be 
previewed thoroughly before exporting.

•	 Image Resolution is the number of pixels per inch (ppi) in a bitmap image. Using too low of a resolu-
tion for a printed image results in pixelation – output with large, coarse-looking pixels. Using too high of 
a resolution (pixels smaller than what the output device can produce) increases the file size and slows the 
printing of the artwork.

•	 Printer resolution and screen frequency refers to the number of ink dots produced per inch (dpi) and 
the number of lines per inch (lpi) in a halftone screen. The relationship between image resolution, printer 
resolution, and screen frequency determines the quality of detail in the printed image.

Placing Bitmap Images
You can import bitmap images into an Illustrator document using the Open, Place, and Paste commands; 
however the Place command is the primary method of importing, because it provides the highest level of 
support for file formats, placement options, and color.

To place a bitmap file:
1.	 Choose File > Place, and browse to the file you want to place.
2.	 Select Link to create a link to the file, or deselect Link to embed the artwork in the Illustrator document. 

(More about linked artwork below.)
3.	 Click Place.
4.	 In certain situations, another dialog box appears:

•	 If you place a PDF file with multiple pages, you can choose which page you want to place and how 
to crop the artwork.

•	 If you embed a Photoshop file, you can choose how to convert layers.

After you place a file, use the Links palette to identify, select, monitor, and update it.

2.) Placing Photographs
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There may be times when you want to base a new drawing on an existing piece of artwork. For example, 
you may want to create a graphic from a pencil sketch drawn on paper or from a raster image saved in anoth-
er graphics program. In either case, you can bring the graphic into Illustrator and trace over it manually or 
use the Live Trace feature to trace it automatically. With Live Trace, you can control the level of detail and 
how the tracing is filled. When you are satisfied with the tracing results, you can convert the tracing to vector 
paths or a Live Paint object.

Automatically Tracing Artwork
•	 Open or place a file in Illustrator to use as the source image for the tracing.
•	 To trace the image using a tracing preset open the Live Trace menu in the Control Panel and select a pre-

set (See Figure 4).
•	 To set tracing options before you trace the image, select Tracing Options from the bottom of the Live 

Trace menu or choose Object > Live Trace > Tracing Options.

Once you create a tracing object, you can adjust the results at any time by selecting the tracing object viewing 
the Tracing Options as described above. In the Tracing Options dialog box, check the Preview box to see the 
effects as you make adjustments.

You can also create you own tracing presets if you work with similar tracing objects frequently.

To create a custom tracing preset:
•	 Choose Object > Live Trace > Tracing Options to open the Tracing Options dialog box.
•	 Set the tracing options the way you want them.
•	 Click the Save Preset button and enter a name for the preset. Click OK.

3.) Live Trace

Figure 4 – Live Trace in the Control Panel

Figure 5 – Original Image (left) Converted Vector Paths (middle) using 
Live Trace, Painted Vector Path (right)
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As mentioned above, when you place artwork, you can choose whether to link to the file or embed it in the 
Illustrator document:
•	 Linked artwork remains independent of the Illustrator document, resulting in a smaller Illustrator file. 

You can modify linked artwork using transformation tools and effects; however, you cannot select and 
edit individual components in the artwork in Illustrator.

•	 Embedded artwork is copied into the Illustrator document, resulting in a larger Illustrator file.

To determine if artwork is linked or embedded, use the Links palette.

The Links Palette
You use the Links palette to see and manage all linked or embedded artwork in an Illustrator document. The 
palette displays a small thumbnail of the artwork and uses icons to indicate artwork’s status. To display the 
Links palette, choose Window > Links (See Figure 6).

•	 To hide or change the size of the thumbnails in the Links palette, select Palette Options from the Links 
palette menu, and select an option for displaying thumbnails.

•	 You can sort items based on name, kind, or status and show or hide different types of linked graphics by 
selecting commands from the palette menu.

•	 Double-click on an item in the Links palette to view information about the linked artwork.

Updating Linked Artwork
As mentioned earlier, you can only modify linked artwork using transformation tools and effects but you 
can’t select and edit components of the actual artwork. Linked artwork can, however, be edited in the source 
file and updated in Illustrator.
Here are three methods to update a linked file:

•	 In the Links palette, select the link and click the Edit Original button or choose Edit Original from the 
palette menu.

•	 Select the linked artwork on the Artboard and in the Control palette, click the Edit Original button.
•	 Select the linked artwork and choose Edit > Edit Original.

The file will open in its default application where you can make and save changes to the file.

You can also open the linked file independently in another application to edit it. After you save the changes, 
update the link in Illustrator by clicking the Update Link button at the bottom of the Links palette.

Figure 6 – The Links Palette

4.) Managing Linked Graphics
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A clipping mask is an object whose shape masks other artwork so that only areas that lie within the shape 
are visible – in effect, clipping the artwork to the shape of the mask. The clipping mask and the objects that 
are masked are called a clipping set and are marked with a dotted line in the Layers palette. You can make a 
clipping set from a selection of two or more objects or from all objects in a group or layer.

You can mask any artwork that you want, however only vector objects can be used as clipping masks and all 
stroke and fill properties will be removed when an object is converted into a clipping mask.

The objects that you mask are moved into the clipping mask’s group in the Layers palette if they don’t al-
ready reside there. If you use a layer or group to create a clipping mask, the first object in the layer or group 
masks everything that is a subset of the layer or group.

You can also use the Transparency palette to create a semitransparent mask.

Creating a Clipping Mask

•	 Create the object you want to use as the mask. This object is called the clipping path. Remember, only 
vector objects can be clipping paths. To use more than one object as a clipping path, group the objects 
first.

•	 Move the clipping path above the object(s) you want to mask in the stacking order.
•	 Select the clipping path and the objects you want to mask either on the Artboard or in the Layers palette.
•	 Choose Object > Clipping Mask > Make (See Figure 7).

5.) Masking Photographs with Shapes

Figure 7 – An Object Used as a Clipping Mask
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You can also create a clipping mask for a layer or group by moving the clipping path and the objects you 
want to mask into their own layer or group. Make sure the clipping path is the top-most object in the group 
and then with the layer or group selected click the Make/Release Clipping Masks button at the bottom of the 
Layers palette or choose Make Clipping Mask from the Layers palette menu.

Modifying Clipping Masks

Editing a Clipping Mask

•	 Select the clipping path in the Layers palette.
•	 Move the clipping path on the Artboard by dragging the object’s center reference point with the Direct 

Selection tool or using the arrow keys on your keyboard.
---------- or ----------

Reshape the clipping path using the Direct Selection tool.

Adding or Removing Objects

To add an object to a clipping mask, drag the object into the group or layer that contains the clipping path in 
the Layers palette.
Likewise, to remove an object from being masked, drag it out of the group or layer that contains the clipping 
path in the Layers palette.

Releasing a Clipping Mask

Here are two easy ways to release a clipping mask:

•	 In the Layers palette, click the name of the group or layer that contains the clipping mask. Click the 
Make/Release Clipping Masks button at the bottom of the palette, or select Release Clipping Mask from 
the palette menu.

•	 Select the group containing the clipping mask, and choose Object > Clipping Mask > Release.
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Web Graphics Formats
Web graphics formats fall into two categories: bitmap and vector. The bitmap formats are GIF, JPEG, 
PNG, and WBMP. The vector formats are SVG and SWF. A brief description of each format follows.

GIF and PNG-8 both compress images with flat color and crisp detail, such as line art, logos, or illustrations 
with type. GIF tends to be the standard since not all web browsers can display PNG-8 files. PNG‑8 and 
GIF files support 8-bit color, so they can display up to 256 colors. The process of determining which colors 
to use is called indexing, so images in GIF and PNG-8 formats are sometimes called indexed color images.

JPEG is the standard format for compressing continuous-tone images such as photographs.

PNG-24 is suitable for compressing continuous-tone images; however, it produces much larger files than 
JPEG format, however it can support transparency whereas JPEG cannot.

SWF, the Adobe® Flash™ (SWF) file format, is a vector-based graphics file format for the creation of 
scalable, compact graphics for the web. Since the file format is vector-based, the artwork maintains its image 
quality at any resolution and is ideal for the creation of animation frames.

SVG is a vector format that describes images as shapes, paths, text, and filter effects. The resulting files are 
compact and can provide high-quality graphics on the web, in print, and even on resource-constrained, hand-
held devices.

WBMP format is the standard format for optimizing images for mobile devices, such as cell phones and 
supports 1-bit color, which means that WBMP images contain only black and white pixels.

Saving for the Web
You use the Save for Web dialog box (File > Save for Web) to choose web file formats, select compres-
sion and color options, adjust the file size, and preview your optimized image. Optimization settings appear 
on the right. You can quickly choose predefined settings, or select format-specific options to fine-tune the 
results of optimization. The file name and file size appear under the original image. Dynamic optimization 
information appears under the preview images:

•	 The current settings
•	 The size of the optimized file
•	 The estimated download time

The Save for Web dialog box gives you the ability to view your Original artwork, a preview of the Op-
timized file, or your original and optimized artwork side-by-side for comparison in 2-Up or 4-Up mode. 
Change modes by selecting the appropriate tab at the top of the dialog box (See Figure 8).

You can also zoom in or reposition you image within the dialog box preview window(s) using the Hand tool 
or Zoom tool found in the toolbar at the left of the dialog box.

Additionally, you can adjust the dimensions of the optimized file by changing the settings in the Image Size 
tab next to the Color Table tab.

The current optimization settings, along with the estimated file size and download time are displayed at the 
bottom of the Optimized preview window. You can change the connection speed that is used to estimate the 
download time by right-clicking in this area of the window and choosing a new connection speed from the 
resulting context menu.

6.) Optimizing Web Graphics
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To optimize an image in the Save for Web dialog box:

•	 Choose File > Save for Web.
•	 Select your preview mode by clicking on the Optimized, 2-Up, or 4-Up tab. The optimization settings 

can be changed for each of the windows. The active window is identified with a blue box around it. If 
switching from 4-Up to 2-Up or Optimized, whichever window is active will be displayed in the new 
view mode.

•	 From the optimization controls at the right of the dialog box, start by choosing a file format form the Op-
timized File Format drop-down menu or choose an optimization preset from the Preset drop-down menu.

•	 Next, fine tune the optimization settings until you are satisfied with the results in your Optimized image 
preview balanced with the corresponding file size (See Below).

•	 Click Save.
•	 Enter a filename and select a destination for the resulting file.
•	 Click Save again.

Optimization Options
There are numerous file formats that can be used to save Web graphics, however there are many similarities 
in the optimization settings between the different formats. The main division is between continuous tone im-
ages (JPEG, PNG-24, WBMP) and indexed color images (GIF, PNG-8). The most commonly used formats 
on the Web are GIF and JPEG so we will look at the options for those two formats, understanding that most 
of these settings will be applicable to the other formats as well.

GIF Optimization
(See the options displayed in the optimization section of the dialog box in Figure 8).

Lossy reduces file size by selectively discarding data (similar to JPEG optimization). A higher Lossy setting 
results in more data being discarded. You can often apply a Lossy value of 5–10, and sometimes up to 50, 
without degrading the image.

Figure 8 – The Save for Web dialog box in 2-Up view
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Color Reduction Method and Colors specifies a method for generating the color lookup table and the 
number of colors you want in the color lookup table. You can select one of the following color reduction 
methods:

•	 Perceptual creates a custom color table by giving priority to colors for which the human eye has greater 
sensitivity.

•	 Selective creates a color table similar to the Perceptual color table, but favoring broad areas of color and 
the preservation of web colors. This usually produces images with the greatest color integrity and is the 
default option.

•	 Adaptive creates a custom color table by sampling colors from the spectrum appearing most commonly 
in the image.

•	 Restrictive (Web) uses the standard 216‑color color table common to the Windows and Mac OS 8-bit 
(256‑color) palettes. (Also known as the Web-safe palette.)

•	 Custom preserves the current perceptual, selective, or adaptive color table as a fixed palette that does not 
update with changes to the image.

Dithering Method and Dither 

Determines the method and amount of application dithering. Dithering refers to the method of simulating 
colors not available in the color display system of your computer. You can select one of the following dither-
ing methods:

•	 Diffusion applies a random pattern that is usually less noticeable than Pattern dither. The dither effects 
are diffused across adjacent pixels.

•	 Pattern applies a halftone-like square pattern to simulate any colors not in the color table.
•	 Noise applies a random pattern similar to the Diffusion dither method, but without diffusing the pattern 

across adjacent pixels. No seams appear with the Noise dither method.

Transparency and Matte determines how transparent pixels in the image are optimized.

Interlace creates an image that displays as a low-resolution version in a browser while the full image file is 
downloading.

Web Snap specifies a tolerance level for shifting colors to the closest web palette equivalents (and prevents 
the colors from dithering in a browser). A higher value shifts more colors.

JPEG Optimization

The JPEG format uses lossy compression which reduces file size by selectively discarding data based on 
areas of similar colors within the image.

Quality determines the amount of lossy compression. A higher the Quality setting preserves more detail in 
the compression algorithm, resulting in a larger file size than a lower Quality setting would.

Optimized creates an enhanced JPEG with a slightly smaller file size. The Optimized JPEG format is rec-
ommended for maximum file compression; however, some older browsers do not support this feature.
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Progressive creates an image that displays progressively in a web browser. The image will display as a 
series of overlays, enabling viewers to see a low-resolution version of the image before it downloads com-
pletely.

Blur specifies the amount of blur to apply to the image similar to that of the Gaussian Blur filter, allowing 
the file to be compressed more.

ICC Profile preserves the ICC profile of the artwork with the file. ICC profiles are used by some browsers 
for color correction. This option is only available if you have saved the image with an ICC profile.
Matte specifies a fill color for pixels that were transparent in the original image. Click the Matte color 
swatch to select a color. Pixels that were fully transparent in the original image are filled with the selected 
color; pixels that were partially transparent in the original image are blended with the selected color.

Figure 9 – JPEG Options
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Bridge is an application that installs when you install either an Adobe Creative Suite 6 component, such as 
Illustrator, or the entire Adobe Creative Suite 6. It allows you to browse content visually, manage metadata, 
and more.It lets you organize the assets you use to create content for print, web, and video. Adobe Bridge 
keeps native Adobe files (such as PSD and PDF) and non‑Adobe files available for easy access. You can 
drag assets into your layouts, projects, and compositions as needed, preview files, and even add metadata 
(file information), making the files easier to locate.

The Adobe® Bridge workspace consists of three columns, or panes, that contain various panels. You can ad-
just the Adobe Bridge workspace by moving or resizing panels. You can create custom workspaces or select 
from several preconfigured Adobe Bridge workspaces.

A. Application bar B. Path bar C. Favorites panel & Folders panel (tabbed) D. Collections panel E. Filter 
panel F. Selected item G. Thumbnail slider H. View options I. Metadata panel J. Keywords panel K. Pre-
view panel L. Search M. Standard workspaces N. Content panel 

Application bar
Provides buttons for essential tasks, such as navigating the folder hierarchy, switching workspaces, and 
searching for files.

Path bar
Shows the path for the folder you’re viewing and allows you to navigate the directory.

Favorites panel
Gives you quick access to frequently browsed folders.

Folders panel
Shows the folder hierarchy. Use it to navigate folders.

7.) Working with Adobe Bridge

Figure 10 – Adobe Bridge workspace
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Filter panel
Lets you sort and filter files that appear in the Content panel.

Collections panel
Lets you create, locate, and open collections and smart collections.

Content panel
Displays files specified by the navigational menu buttons, Path bar, Favorites panel, Folders panel, or Col-
lections panel.

Preview panel
Displays a preview of the selected file or files. Previews are separate from, and typically larger than, the 
thumbnail image displayed in the Content panel. You can reduce or enlarge the preview by resizing the pan-
el.

Metadata panel
Contains metadata information for the selected file. If multiple files are selected, shared data (such as key-
words, date created, and exposure setting) is listed.

Keywords panel
Helps you organize your images by attaching keywords to them.

Organize content and assets
File browsing
From Adobe Bridge you can view, search, sort, filter, manage, and process image, page layout, PDF, and 
dynamic media files. You can use Adobe Bridge to rename, move, and delete files; edit metadata; rotate 
images; and run batch commands. You can also view files and data imported from your digital still or video 
camera. See View and manage files.

Camera raw
If you have Adobe Photoshop or Adobe Lightroom, you can open camera raw files from Adobe Bridge and 
save them. You can edit the images directly in the Camera Raw dialog box without starting Photoshop or 
Lightroom, and copy settings from one image to another. If you don’t have Photoshop installed, you can still 
preview the camera raw files in Adobe Bridge. See Introduction to Camera Raw.

Color management
You can use Adobe Bridge to synchronize color settings across color-managed Adobe Cloud components. 
This synchronization ensures that colors look the same in all Adobe Creative Cloud apps. See Manage color.

Combining artwork
You can combine Illustrator artwork with images from other graphics applications in a variety of ways for 
a wide range of creative results. Sharing artwork between applications lets you combine continuous-tone 
paintings and photographs with vector art. Even though Illustrator lets you create certain types of raster im-
ages, Adobe Photoshop excels at many image-editing tasks. The images can then be inserted into Illustrator.






















